Green background with large Stockman S watermark

System Requirements

 

System Requirements for Online Banking


eBank

Operating System Support
  • Microsoft Windows 7 or newer
  • Apple macOS 10.12.6 or newer

Browsers
  • Apple Safari
    • Version 12 or newer
  • Internet Explorer
    • Internet Explorer 11
  • Microsoft Edge (Windows 10 only)
  • Google Chrome 
    • Current Release
  • Mozilla Firefox 
    • Current Release
  • Opera
    • Current Release
  • Browser must support TLS 1.2
 
Customers with eStatements (Imaged)
  • Any currently supported PDF reader

eMobile

eMobile Phone App
  • iOS version 11 or higher
  • Android version 5.0 or higher
    • eMobile does not support the use of the Android 'Developer options' settings
 
eMobile Tablet App (Mobile Deposit requires a camera of at least two mega-pixels in resolution)
  • Android version 5.0 or higher
  • iOS version 11 or higher

eMobile Browser
  • iOS version 11 or higher
  • Android version 5.0 or higher
  • Browser must support TLS 1.2
  • All other operating systems must use default browser and an unmodified version of the manufacturer-supplied operating system.

eMobile SMS
  • iOS version 11 or higher
  • Android version 5.0 or higher
  • All other operating system must use an unmodified version of the manufacturer-supplied operating system.

eBiz Mobile

eBiz Mobile App (Mobile deposit requires a camera of at least two mega-pixels in resolution)
  • Android version 5.0 or higher
  • iOS version 10 or higher

eBiz

Operating System Support
  • Microsoft Windows 7 or newer
  • Apple macOS 10.12.6 or newer

Browsers
  • Apple Safari
    • Version 12 or newer
  • Internet Explorer (required for PremierACH)
    • Internet Explorer 11
  • Microsoft Edge
  • Google Chrome
    • Current Release
  • Mozilla Firefox
    • Current Release
  • Opera
    • Current Release
  • Browser must support TLS 1.2
 
Customers with eStatements (Imaged)
  • Any currently supported PDF reader

eDirect

Operating System Support
  • Microsoft Windows 7 or newer
  • Apple macOS 10.12.6 or newer

Browsers
  • Internet Explorer
    • Internet Explorer 11
  • Apple Safari
    • Version 12 or newer
  • Microsoft Edge (Windows 10 only)
  • Google Chrome 
    • Current Release
  • Mozilla Firefox
    • Current Release
Browser must support TLS 1.2